inte rsi I m Application Note 1652

Authors: Xuexin Wang and Sameer Dash

iISIm:PE User's Guide

Table of Contents

LT € To 1111 T o 2
Download a Part's Schematic . .. .......cuc ittt i i it at s e et ea s ansansan e snaranaaa s 2
Place CoMPONENES . ... .ottt i i ittt et ct it e et a s e s asan s aa s asasana e e a s 3
Add "Websim' ComMpPONENt .. ...... ..ttt iie i ata e e taananacasnasassasaasanscasnasassasacsasscosnsannannns 4
Add MOSFET/Op Amp SPICE Modelto Library ...........coiiiiiiiii i i ararararasanassnnssasasasasnsnnnns 5
Change Level of Modeling for MOSFET . ... .......ucitii et it tin i ansansasansassansassassannnsansnnsansnssnnns 9
Setupthe Load BoX ...........ioiiiii i ii i ie it ctataescsacsasacaanasacasnasnasaasasansasscsnnscaensnnsnnns 11
Add Probes and View Waveforms . .. ... ... ittt i it et et se s aaaa s an s asa e an e e 12
Setting Initial Conditions . ....... ...ttt i i it ii st et et e e e 16
Run Simulation .. ... i it it at et a i an s a s 16
L1 2 1= 0T 0 T T 19
Possible Causes of POP Failure. . ... ... .cii ittt ittt et iaea s a s ansansansannasnnsnassnnnnssnnnnnns 21
Probe Noise in Opamp CirCUit . ......... ... .ttt ittt e taeecracaasacoanasasscasacsnasscasnasansasnnnnns 21
How to Display DC BIas VOItage .. .....vuviutoitinieiinanansesssnnassasessansansnnnssnnsnssnnnnssnsnnsns 21
How to Run Monte Carlo Simulation. . . .......ccii i i ittt ai e aa e asnnasaasassnnnassnnnnrns 23
00 1o 1T [ o 25
0T £ =Y T 25
December 21, 2011 1 CAUTION: These devices are sensitive to electrostatic discharge; follow proper IC Handling Procedures.
AN1652.1 1-888-INTERSIL or 1-888-468-3774 | Copyright Intersil Americas Inc. 2011. All Rights Reserved

Intersil (and design) and iSim are trademarks owned by Intersil Corporation or one of its subsidiaries.
All other trademarks mentioned are the property of their respective owners.



Application Note 1652

Introduction

Intersil offers a powerful offline schematic capture and circuit
simulation tool called iSim:PE (short for iSim Personal Edition). It

is based on the SIMetrix/SIMPLIS® sim

to download iSim:PE is located in the iSim™ homepage:

http://www.intersil.com/isim

SIMetrix® is a mixed-mode circuit simulation engine. iSim:PE
offers SIMetrix® as a powerful SPICE simulator for Intersil's Op
Amp SPICE models. It is a full-featured schematic entry and

waveform viewer tool.

ulation platform. The link This application note highlights the most frequently used

functions on iSim:PE that an engineer would need to "virtually
prototype" a circuit design using Intersil parts.

iSim:PE essentially runs two user-selectable and highly

complementary simulators: SIMPLIS® (for Intersil's Power

Management parts) and SIMetrix® (for

SIMPLIS® is a leading simulation engine for simulating highly
non-linear systems such as switching power supplies. It uses

piecewise linear analysis techniques to

which results in transient simulations 10 to 50 times faster than
SPICE [1]. The AC analysis is based on the full time-domain
switching model of the converter, and there is no need to derive

the averaged model of the device.

In order to view the time-domain and frequency domain response
of a switching circuit, the simulation must quickly reach the

Download a Part's Schematic

When using iSim online tool, once the tool generates the
schematic, you can download it from the design page and design
summary page. The design page is where you can edit the
component values on the schematic and perform simulation as
shown in Figure 1. The design summary page is where iSim
summarizes input requirements, schematic, simulation result
and bill of materials as shown in Figure 2. The "Download
Schematic" tab is located on the top right corner of the two
pages. Once you click the "Download Schematic" tab, you will be
asked to save the file to your PC with extension “.sxsch”.

Intersil's Op Amp parts).

model non-linearity,

steady-state periodic operating point (POP), which is a highly

computationally intensive process. The

use of piecewise linear

models helps achieve the desired accuracy in a very short time.
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FIGURE 1. DOWNLOAD SCHEMATIC FROM DESIGN PAGE OF iSim ONLINE TOOL
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FIGURE 2. DOWNLOAD SCHEMATIC FROM DESIGN SUMMARY PAGE OF iSim ONLINE TOOL

Place com ponents Figure 3. Once the symbol has been _selected, drag the image of
the component to your desired location on the schematic and

If it is a simple device like a resistor or capacitor, select the left-click. This will place the component on the schematic. Use

appropriate symbol from the toolbar or go to Place menu. For the right-click button or ESCape key to cancel placing the

other devices that require a part number, go to Place -> From component.

Model Library and select your desired device as shown in
", untitled [5elected)

File Edit “iew Simulator | Place Probe Probe 4C/Moize  Hierarchy mﬁhﬂu’ehﬁim

”E? £T nmﬁlﬂ{] Repeat Last Place...  Al+R D=+ ®Hsg ¥FELEIEELET 1::>|
From Model Library...  Ctil+G
urnamed | Fram Symbal Library. .. l

Hierarchy 3 Tool bar
Create Model k

Magnetics 3

Pazsives 3

Connectars 3

Frobe 3

Yoltage Sources 3

Current Sources 3

Contralled S ources 3

Bias &nnaotation »

Semiconductars »

Digital 3

Digital Generic 3

Analog Behavioural 3

Analog Functions 3

Wiorksheets k

FIGURE 3. PLACE COMPONENT
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Add 'Websim' Component

iSim:PE contains a library of custom-made components that can
be used with Intersil IC models. Click WebSim -> Add WebSim

components, and then click on the component you want to add,

as shown in Figures 4 and 5.

C:\Documents and Settings\sdash\DesktopM5im\PARTSASLBOO9ANntersil_iSimPE_ISLBOO9A.sxsch |

File Edit ‘iew Simulator Place Probe Probe AC/Moise Hierarchy | WebSim

Interzil_iSimPE_ISLE0034, suach l

e

FIGURE 4. OPEN WEBSIM COMPONENTS LIBRARY

& Select Symbol n

Intemal name: websim_scap2

Symbols

[

Z-WebSim Components
\Websim Bode Probe
—WebSim Load
—WebSim Load with Double-Sided Transent
=-websim ALCs

~\WebSim Capacitar

-~ \WehSim Capacitor with ESR Shunt ESL

~w'ehSim Electrolytic Capacitor with ESR

Sim Electrolytic Capacitor with ESR and ESL

- WebSim Industor with DCR

-~ webSim Inductor with DCR,ASH

—WebSim Inductor with Mo DCR

websim Mon-Electioltic Capacitor with ESR
~Websim Mon-Electrolplic Capacitor with ESR and ESL
~'w'ehSim Resistor [Box shape]

~WebSim Resiztor [£ shape)]

ebsirn Semconductons

~w'ebiSim N-channel Power MOSFET

—WebSim N-channel Power MOSFET with Coss
~webSim M-channel Power MOSFET with linear Cgd and Cds
[ Websim Optocoupler

‘webSim P-channel Power MOSFET

—Webzim Zener Diode

=-Websim Sowces

~\webSim Battery

- \WebSim Battery with ESR

-~WebSim DC Current Source

~webSim Fit 5-bit VID DC source
~webSim Fix 6-bit VID DC source
~wiebSim Fec 7-bit VID DC source
~w'ebSim Fix 8-bit W10 DC source
~WebSim Fix OC Source

~WebSim Pulse Voltage Source

-~ WWiebSim Sine Voltage Source for SIMETRI<
~webgsim Sine Yoltage Source for SIMPLIS
\wfebSim Step Current Source

=\WebSim Step Yoltage Source

4 -WebSim Transformers

=whebSim 1P-15 Cunent Kformer
~WebSim 1P-15 Current former as a current controlled current source
S webSim 1P-15 Cunent Xlormer with Lmag

Cancel

o |

FIGURE 5. SELECT WEBSIM COMPONENT
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Add MOSFET/Op Amp SPICE
Model to Library

The iSim:PE model library contains a comprehensive collection
of MOSFETs for use in both analog/mixed signal as well as power
management applications. It contains over 2000 models for
NMOS parts from various vendors. In addition, the WebSim
library contains generic models for MOSFETs with different levels
of complexity that the user can edit.

It is easy to add a model of another MOSFET to the library. This
feature is useful when the designer has decided on the MOSFET
part number and wants to see more accurate simulation results.
The following steps will guide the user to add the FET model to
the library:

1. Download the PSPICE model of the MOSFET to your computer.
This can usually be found on the vendor's product website.
The file is typically a ".lib' or '.txt' file containing the PSpice
model.

2. Open the folder containing the PSPICE file; left-click and drag
the file into the iSim:PE Command Shell

3. A message box will pop-up asking if you want to install the file
as shown in Figure 6. Click OK. You will see a confirmation on
the iSim: PE Command Shell as shown in Figure 7.

4. Now, a symbol needs to be associated with this model. Go to
File -> Model Library -> Associate Models and Symbols, as
shown in Figure 8. Choose the category (for example, NMOS)
and symbol (such as, NMOS 3-terminal) corresponding to the
model as shown in Figure 9. Click Apply Changes and then
click OK.

5. The model has now been added to the NMOS library. To place
this MOSFET in the schematic, go to Place -> From Model

Library -> NMOS as shown in Figure 10. Select the part
number in the library shown in Figure 11 and click Place to
place in the schematic.

The procedure for adding the OPAMP model to the iSim:PE
library is very similar to adding the MOSFET model. There is only
a slight difference when associating the model to the symbol.
Figure 12 shows that you need to select Op-amps from the
Choose Category dropdown box and Operational Amplifier - 5
terminal from the Define Symbol. The number of terminals is the
number of external pins that are defined in your opamp model.
Make sure to Apply Changes before clicking OK.

% Install Models x|

\c]p) Install file C:i\Documents and SettingstsdashiDeskioptsirda2dp. b ?
-

Cancel |

FIGURE 6. INSTALL MODELS

#! iSim PE Command Shell - [of x|
File Simulator SIMPLIS Graphs and Data Help

[y [making device caralog. This may take some time, please wait...
Completed

% O | = &L

FIGURE 7. MESSAGE SHOWING MODEL INSTALLATION IS
COMPLETED
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g iSim PE Command Shell !EE |
File Simulator SIMPLIS Graphs and Data Help .
New Schematic 715 may take some time, please wait...
New Schematic Window )
nis may take some time, please wait...
Open Schematic. ..

15059040 created for SiR462DP
Open Last Schematic  Ctrl+F9

Reopen »
Save

Save As... A

Save All...
Save Session

Restore Session

Data L4
Graph »
Symbol Editor 3

Add/Remove Libraries. ..
Change Directory... View/Remove Libraries...
Brint ... Associate Models and Symbols...
Options » Re-build Catalog
‘Windows » Create Library Dictionary. ..
Edit File
Wiew File
Exit

FIGURE 8. ASSOCIATE MODELS AND SYMBOLS STEP 1

i Associate Models and Symbols EE

Select Devices Choose Category

[ Unknown ™ > | [nwos | MNewCategory... |
SIMPLIS_DIGI_SRFF_SR_N (SIMPLIS) Al
SIMPLIS_DIGI1_SRFF_SR_Y [SIMPLIS) Define Symbol
SIMPLIS_DIGI1_SRFF_Y (SIMPLIS) -
SIMPLIS_DIGH_SRLATCH_EN_N (SIMPLIS) | NMOS 3 terminal =] Auto Creae Symeal|
SIMPLIS_DIGI1_SRLATCH_EN_Y (SIMPLIS) .
SIMPLIS_DIGI1_SRLATCH_N (SIMPLIS) Plnjorder il LI o
SIMPLIS_DIGI_SRLATCH_Y (SIMPLIS) D A
SIMPLIS_DIGI_TFF_N (SIMPLIS) G
SIMPLIS_DIGI_TFF_SA_N (SIMPLIS) 5 S g
SIMPLIS_DIGI_TFF_SR_Y (SIMPLIS] -
SIMPLIS_DIGI_TFF_Y (SIMPLIS) . o
SIMPLIS_DIGI1_XOR_N (SIMPLIS)

SIMPLIS_DIGIN _XDR_Y [SIMPLIS)
SiR462DP ¥

Edit Pin Names... I

Electrical Model - 5iR462DP

From: C:\Documents and Settings\sdash\Desktop\sir462dp.txt, line 7 -
*September 15, 2008

*Doc. ID: 64317, ECN 5-82133, Rew. A

*File Name: S1R462DP_PS.txt and SiR462DP_P5.11b

*This document is intended as a SPICE modeling guideline and does not

*constitute a commercial product data sheet. ODesigners should refer to the

*ﬁ:.ri'oprute data sheet of the same number for guaranteed specification

= rs.

-SUBCKT SiR462DFP D G S

M1 3 GX S S NMOS W= 2803299u L= 0.25u

M2 S GX S D PMOS W= 2803259u L= 2.218e-07 ﬂ
R1 D 3 5.385e-03 TC=4.324e-03. 8.998e-06

Apply Changes | ok | Concel |  Hep |

FIGURE 9. ASSOCIATE MODELS AND SYMBOLS STEP 2
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% C:\Documents and Settings\sdash\Desktop\iSim\PARTS\ISL BOO9A\Inte
File Edit Yiew Simulator Place Probe Probe AC/Moise Hierarchy ‘WebSim

OO ||* 6§  RepeatlastPlace.. At+R P || ) F M+

From Model Library.., Ctri+G

Intersil_iSimPE_ISLE0034 « From Symbol Library. ..
Hierarchy »
Magnetics 3
Passives »
Connectors 3
Probe »
Yoltage Sources 4
IVBA Current Sources » VIN
[T =t
Controlled Sources »
Bias Annotation »
41 Semiconductors » EN
ESR=3m —_ Digital b POR
VRAT SIMPLIS Primitives b
Analog Functions » BHP
=l Worksheets »
FIGURE 10. OPEN MODEL LIBRARY
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' Select Device m

* Recently Added Models
" allUser Models *
* All Models *
Capacitors

Diode

Gates

NMOS

NPN

PMOS

PNP

PSU Controllers
PSU Drivers
SIMPLIS

SIMPLIS Blocks
Varactor Diodes
Voltage References
Zener Diodes

% ||k nown

Filter I

C:\Documents and S ettings\sdash\Desktop\sird62dp. tat

45NG10T
47NG10T
PSONO3LT /PS
SENOILT/PS
PEINO3LT /PS
PG7NO3LT /PS
N 20T
ENOBLT
GNOBT
SNOBLT
108NQO3LT
77N003T
78NOOILT
F170
F170/PS
1370¢N
2605N
|3405N

40uM
NOD4-25B/PS
NOD4-25P/PS
NOOS-55B/PS
NOOS-55P/PS
NOOS_25D
NOOS_30K
NO15-1008/PS
NOT5-100P/PS
K 43086
k43088
K43090

Kl

RF1K49092N
RF1K49156
RF1K49157
RFD14N0S
RFD14NO5L
RFD14NOSLSM
RFD14N055M
RFD16NO3L
RFD16NOILSM
RFD16NOS
RFD16NO55M
RFD16NOS
RFD16NOBSM
RFD7N10LE
RFDZN10LESH
RFP14NOS
RFP14NOSL
RFP7N10LE
Si4410DY
514420DY
514800
5i3410DY
Si9936DY
Si9936DY /<P
Si9945DY
599550y
5i9956DY
SIPCOTNSOC2_L1
SIPCO2NB0SS_L1
SIPCO3NBOC3_L1

o[ ]

SIPCO3NBOS5_L1
SIPCOSNBOC3_L1
SIPCOSNBOSS_L1
SIPCOSNSOC3_L1
SIPCOSNBOC2_L1
SIPCOSNBOC3_L1
SIPCOSNEOSS_L1
SIPCO7NSOC3_L1
SIPCOSNSOC3_L1
SIPC10NBOC2_L1
SIPC10NBOC3_L1
SIPC10NBOSS_L1
SIPC13N80C3_L1
SIPCT4NBOC2_L1
SIPCT4NBOC3_L1
SIPC14NB0S5_L1
SIPCISN10L_L1
SIPC1ENSOC3_L1
SIPC26NBOC2_L1
SIPC26NBOC3_L1
SIPC26NBOSS L1
SIPC26NBOC3 L1
SIPCEINBOSE_L1
SIPCEINGOC2_L1
SIPCBANBOC3_L1
SISCO_3NOSE1_0_LO
SISCO_3NOBET_0_L1
SISCO_3NOBET_4_LO
SISCO_3NOBET_4_L1

| 2|

Concel | Help

|

FIGURE 11. SELECT A MOSFET MODEL
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B Associate Models and Symbols

Select Devices Chooze Category

iDp-amps ﬂ || Oprarmps I
EL2045 ELS106 ELGI67 HA2520 HAS12Z7 I1SL28136

ﬂ Mew Category...

EL21 2L5192 HAZ522 HA5137 ISL25158 Define Symbol
EL2128) -EL'S‘IZUT L5193 HA2539 HFA1100 1SL28158 I
EL218D L5220 HAZS40 HFATI0S ISL28190 A L T Auto Create Symbol

EL2227 ELS160 ELS262 HAZE00 |SL24021 ISL281H i

ELS100 ELS161T ELBID0 HAZ2620 |SL28107 1SL28194 P o L] ll
ELS101  EL5162 ELBIOT  HAS5020 |SL28113 1SL26195 inp

ELS102 EL5163 ELEI02 HAS0D23 |5L28114 ISLS5001 inn

EL5103 ELSIB4 EL8103 HASD24 ISL28117 LF412R vip

ELS104 ELSIBS ELBI0S HAS102 ISL28127 TLO72R vin

EL5105 ELS166 ELB176  HA5104 1SL28133 out

Edit Fin Mames...

Electrical Model - EL51207

From: G:\CAPPS\_Cent Apps Employees’uexin WATraining\ELS120T_v2.txt, line 16
*EL5120T EL5220T EL5420T Macromodels

version 2.0, by Jian wang 11/13/2003

Copyright 2009 by Intersil Corporation

Refer to data sheet "LICENSE STATEMENT" Use of

this model indicates your acceptance with the

terms and provisions in the License Statement.

12MHz, precision Rail to rail input and output amplifier
The AC response for this model is based on Vsm+/=5V
SR,0pen loop gain are modeled.

voltage noise are modeled, not good.

connections: +inout

L

LA S A

Cancel

|

Help ‘

FIGURE 12. ASSOCIATE MODELS AND SYMBOLS FOR OPAMP

Change Level of Modeling for
MOSFET

As mentioned in the previous section, SIMPLIS® uses a generic
MOSFET as shown in Figure 13 in simulation. These generic
MOSFETs only model rpgon) and Cgs (gate-to-source
capacitance), which result in ideal switching waveforms for Vpg
(drain to source voltage) and Ip (drain current) as shown in
Figure 14. Despite these limitations, they provide a good
approximation of circuit behavior and enable faster simulation
times.

To get more accurate simulation results, you must change the
model level of the MOSFET. Right-click the model and select Edit
Additional Parameters. A small box will pop up, as shown in
Figure 15. If you change the model level from 1 to 2, the model
will include parasitic capacitance of Cgg and Cpg. Figure 16
shows the switching waveform where there are switching losses
when using model level 2.

Q1
= 10.0m

= 1.0n
1x
— |_

FIGURE 13. GENERIC MOSFET MODEL
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FIGURE 14. SWITCHING WAVEFORM USING LEVEL 1 MOSFET MODEL

ivcc Lon.u:m | ] “l Luuun _I_‘-TBAT
-

ESR=1.00] CING vic cum -:m — ESR=1.0m
5.0 1= ISLES45A 330u 1? 0

= R=
- EOOT Es 1 nm .......... T
S1420DY
COMP
I s
ga7.00
BF <
I3 L
CHF
38n
oF ] FB §1447  Probe Voltage... B Edit Device Parameters
] - \ ProbsCurert,.,
1.00K . o Display Device Bias Info IErM e [51.838 =
FFSET © . VDM 30 5451 =
J_ SHD . Edit[Add Properties. .. o =
il Roce  Delete Properties... Tempeishae [25 =
- Mirve Tat -
Mhodel Level | 00007 -
- - EoR St L 0 0001
RIN Uipadabe Shbeod ok 10011
1.00K Riestors Properties. ..
27 i fe BODOE
P 33 20
FIGURE 15. EDIT THE MODELING LEVEL
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Da1 /A

Millsf Capacitance I

. VGS /

4 < /

, /N /

A\ /
‘*-___h_‘_'___,___,————-——'—

2 L_ i

32 3.5 33 3= 34 3n 35

time/uSecs

S0nSecs/div

FIGURE 16. SWITCHING WAVEFORM USING LEVEL 2 MOSFET MODEL

Setup the Load Box

POP analysis needs a resistive load, as shown in Figure 17, to

converge quickly. The load box is a resistor with a current source

in parallel, as shown in Figure 18.

DCR=100m
Lour
IC=125m

VYTV, »

ILOAD

1u
ESR=5m +
IC=339
4.7u
cout
1

FIGURE 17.

Rib CFB

LOAD BOX SYMBOL

4 IFINAL=250m

ISTART=0
RISE=1u
DELAY=40u
RSRC=33

L LOADT
314k afp —_—

FIGURE 18. INTERNAL MODEL OF LOAD BOX

In Figure 17: Start and Final Current are relative to Voyt and
Source Resistance (Rgrc)

* In this example, Voyt = 3.3V, Rgrc = R1 =33Q
* Current through Rgpc: Ispc = 3.3V/33Q2 = 100mA

* For the current source in parallel with Rgre, IstaRT = O,
IFlNAL =250mA
* For the load box:
- Actual Start Current = IgyaRT + IsRc = 0 + 100mA =100mA

- Actual Final Current = IgyaL + Isrc = 250mA + 100mA =
350mA

The simulated waveform in Figure 19 shows the Vgyt and I oap
plots using this load box.

ILOAD / ma,
g

WOUT /%

W

(1] 20 40 (=] an

140 160 180

timefuSecs 20uSecs/div

FIGURE 19. SIMULATION RESULT SHOWING LOAD TRANSIENT
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Add Probes and View Waveforms

There are two approaches to create plots of simulated results
from a schematic. The first one is to place fixed probes, which
are added before a run. The most commonly used fixed probes
are as follows:

1. Fixed voltage probe - plots single-ended voltage. Go to Probe
-> Place Fixed Voltage Probe as shown in Figure 20, and put
it at the node you want to look at.

2. Fixed inline current probes - plots the current flowing through
it. Go to Probe -> Place Fixed Inline Current Probe and put it
in the wire, as shown in Figure 21.

3. Fixed differential voltage probe - plots the voltage between
two points. Go to Probe -> Place Fixed Differential Voltage
Probe and connect the two points to the positive and negative
input of the probe, as shown in Figure 22.

You can edit the properties of the probes in the Edit Probe
window, as shown in Figure 23. The window will appear by
double- clicking the probe. In this window, you can edit the name
and select the axis and graph for each probe.

The following example shows how to use this feature to plot four
different probes (Vout, ILoaD: ILouT @nd Igoyt,shown in

Figure 21) in one graph. The last three probes will be plotted in
the same grid as they are all current probes. First, open the Edit
Probe window. Check the box next to Use separate graph and
name the graph. Use the same name, for example, "OUTPUT" for
all these probes. Then, assign | gap, ILouT and Igoyt to the same
grid. To do that, check the box next to Use separate grid and use
the same name; for example, "l gpp" for these three probes.

Figure 24 shows the simulation result. In this graph, all the
current waveforms are plotted on a separate axis, named
"lILoap"; While Vgur is on the default axis.

The second approach is to randomly probe the circuit. This type
of probe is added after the simulation is complete, so it is often
used as a complement of the fixed probes. The most commonly
used types of random probes are the same as fixed probes. Here
we just take a random voltage probe as an example. Go to
Probe -> Voltage (shown in Figure 25), and click the node you
want to look at. This will create a new curve. The random probes
will not be updated after a run, so you must add them manually
every time simulation is complete.

4. H:ATraininghiSimGeneral_Centapps\intersil_iSimPE_ISLB502.sxsch [Selected]

File Edit “iew Simulator Place | Probe Probe AC/Moise Hierarchy ‘WebSim

Fepeat last probe...
Add Curve...

ez T S[6f % %

o IR - e /|

Intersil_iSimPE_|SLA502 sxzch | Yoltage...

Yaltage [Mew graph sheet)...
Yaltage - Differential...
Yoltage - Digital ..
Yoltage - AC coupled...

WH Yoltage - Bus...

AN . X .
Current in Device Pin...

Current in %fire. ..

som L1 Curent in Device Pin [Mew graph shest]...

More Probe Functions...

Fawer In Dewvice...

IDQHS

IC=10 -
ESR=1.37m l Faourier
= Mews Graph ‘window

Mew Graph Sheet

Place Fized Curent Probe. ..

Delete Al Fised Probes

Place Fized Inline Curent Probe

—L10 Place Fized Diff. Yoltage Prabe...
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FIGURE 20. PLACE FIXED VOLTAGE PROBE
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FIGURE 21. PLACE FIXED INLINE CURRENT PROBE
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FIGURE 24. SIMULATION RESULT SHOWING THE PROBES SETTINGS
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FIGURE 25. PLACE RANDOM VOLTAGE PROBE
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Setting Initial Conditions

It is advisable to set the initial conditions of switching
components on the schematic; most commonly, capacitor
voltages and inductor currents. Although not necessary, setting
these values helps the simulator to quickly converge to the
periodic operating point.

To set the initial condition, double-click on the component, set
the value (current for inductors and voltage for capacitors), and
check the box for Use Initial Condition.

@ Edit Device Parameters

IC=850m
Lour
DCR=56m
YTV -

Inductance [184

= DC Winding Resistance |56m

Initial Condition [650m

o lele

l
¥

18u

b

Ll

¥ Use Initial Condition

[ Excluded from simulations j Ic8

Ok Cancel

FIGURE 26. SETTING INITIAL CONDITIONS

Run Simulation

iSim:PE uses the SIMPLIS/SIMetrix® simulator, which is a circuit
simulator designed for rapid modeling of switching power
systems, while SIMetrix® is a mixed-signal simulator based on
SPICE. Here we focus on the introduction of a running simulation
in SIMPLIS®. There are three simulation options in the iSim:PE
SIMPLIS® simulator: POP, AC and Transient. POP stands for
Periodic Operating Point. It finds the steady-state limit cycle, or
the periodic operating point of a periodically switching system,
without having to simulate the entire power-up sequence. This
dramatically speeds up the analysis of the design's behavior
under different load conditions [1].

iSim:PE has the ability to perform small signal analysis and
provide the Bode plot of the control loop for the switching power
supply circuit. If you run a POP analysis before AC, there is no

need to build an average model, which is required in SPICE.
Similar to a network analyzer, iSim:PE uses an AC source and a
Bode probe. As shown in Figure 27, the unit-less AC source
injects a varying frequency signal into the feedback loop. The
Bode probe plots the phase and gain of the circuit.

To run a simulation, go to Simulator -> Choose Analysis, as
shown in Figure 28. The simulation options will show on the right
side of the pop-up window.

A successful POP analysis is required in order to run an AC
analysis. Thus, the POP check box is automatically checked when
AC is checked. Under the AC tab, you can change the sweep
frequencies and points per decade.

Figure 29 shows the analysis parameters for a Transient
simulation. Normally, you only need to change the "stop time"
and keep the other default settings. Note that you need to check
the box next to POP manually when only running Transient
analysis. Click OK to save all the settings.

Click Run from the drop-down menu of Simulator or press F9 to
run simulation. The status window shown in Figure 30 appears.
You can click Abort to terminate the simulation. If you check the
box next to Close on completion this window will close
automatically after the simulation is done.

Simulation graphs will be plotted in the waveform viewer. Graph
cursors can be used to make measurements from waveforms.
Go to Cursors -> Toggle On/Off to switch the cursor display on or
off. A hint box will show up for first-time users.

In the example shown in Figure 31, we move the second cursor to
the point where the closed loop gain equals 0dB. The
corresponding frequency is the bandwidth of the system, and the
phase value is the phase margin. Note that, in this plot, what is
shown as phase is actually phase margin. If you want to plot
phase in the simulation result, you must change the Bode probe
setting before running simulation.

Double clicking the Bode probe opens the Edit Device
Parameters window shown in Figure 32. Check the box next to
"Multiply by -1". Figure 33 shows the AC simulation result where
phase is plotted instead of phase margin.
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FIGURE 27. AC SOURCE AND BODE PLOT PROBE
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FIGURE 29. TRANSIENT ANALYSIS SETTINGS
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FIGURE 30. SIMULATION STATUS
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FIGURE 32. BODE PROBE SETTINGS
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FIGURE 33. BODE PLOT SHOWING PHASE

Waveform Viewer

The following example shows how to move a curve to a separate
grid and how to apply measurement to the curves in the
waveformviewer. In this example, we want to look at VPHASE.
Click the New Grid tab in the tool bar, as shown in Figure 34, and
a new grid will be created in the waveform viewer.

Select VPHASE by checking the box next to the legend which
designates the curve. Select the new grid by clicking it. Click the

Move Curve to Selected Axis/Grid tab in the tool bar. Now
VPHASE is in the new grid (Figure 35).

If you want to perform an accurate measurement, select the
waveform by checking the checkbox and then go to Measure in
the menu bar. In this example we measured the frequency of
VPHASE (Figure 36). The measurement result is shown under the
legend of the curve.
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FIGURE 34. CREATE A NEW GRID
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FIGURE 35. MOVE CURVE TO SELECTED AXIS/GRID
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FIGURE 36. MEASURE FREQUENCY

Possible Causes of POP Failure

POP (Periodic Operating Point) analysis works on the full
time-domain switching model of the circuit and is required to
perform AC analysis.

The SIMPLIS® simulation engine takes a snapshot of all inductor
currents and capacitor voltages at the beginning of one switching
cycle and another snapshot at the beginning of the next cycle (a
clock-edge trigger or POP-trigger is used to capture these
snapshots). It then tries to find a set of initial conditions that will
drive this difference to less than ~10109% [2]. The closer you are
to the actual steady-state conditions, the sooner the circuit will
reach POP.

The following are the most common causes of POP failure:

1. Initial conditions (of capacitor voltages, inductor currents,
etc.) are too far from their steady-state values.

2. Circuit is not stable.

3. POP trigger is not connected to a proper node so that a trigger
signal is generated once every complete conversion cycle

4. POP analysis settings constrain the analysis so that:

a.Max Period (Menu -> Simulator -> Choose Analysis ->POP)
is less than the conversion period of one switching cycle.

b.Max Period is too large.
c.Number of POP iterations is too small.

For most iSim:PE schematics with the correct component values,
POP can be reached just by setting the correct initial conditions.
Run only Transient analysis (without any change in LOAD) long
enough so that the important switching waveforms in the circuit
appear to have reached steady state. Then go to Options->
Simulator -> Initial-Conditions -> Back-annotate. This will assign
steady-state initial conditions to all components and make the
circuit reach POP faster.

Probe Noise in Opamp Circuit

This example shows how to plot noise in SIMetrix®. First open
the Choose Analysis window, as shown in Figure 37. Make sure
you select Noise simulation in the Analysis Mode. You can define
the sweep frequency and output node. Then run the simulation.

The noise waveform does not come out automatically after the
simulation is done. Go to Probe AC/Noise -> Plot Output Noise. If
you are sitting at the transient waveform before plotting the
noise, the noise figure will be shown in a separate graph.
However, if you are looking at the Bode plot, the noise will be
plotted on the same graph, with a different Y-axis. Figure 38
shows the simulated noise for ISL28191 at unity gain. It shows
that the noise is 1.7nV/VHz at 1kHz, which is the same as the
specification in the ISL28191.

How to Display DC Bias Voltage

You can view DC operating point results by placing markers on
the schematic as shown in Figure 39. Go to Place -> Bias
Annotation. To place voltage markers at all nodes select, Auto
Place Voltage Markers. The DC voltage at each node will be
shown at the sharper side of the marker after each simulation
run. This option, however, clutters up the schematic so you may
prefer to place markers manually by selecting Place Marker.
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FIGURE 39. PLACE VOLTAGE MARKER

How to Run Monte Carlo
Simulation

Monte Carlo is a method of analysis that uses random sampling
techniques to obtain a probabilistic approximation to the solution
of a mathematical equation or model. Using this same approach
applied to the resistors and capacitors will show the effect of
parameter variations. The following example uses Monte Carlo to
look at frequency response and step response when component
values are not exact values but with tolerance.

First, set tolerance for the resistors and capacitors. Go to
Monte-Carlo -> Set All Resistor Tolerances. Enter the tolerance
value in the pop-up window. In Figure 40, we use 2% for the
resistors.

Similarly set the tolerance for capacitors in Set All Capacitor
Tolerances to 5%.

Go to Simulator -> Choose Analysis to open up the analysis
settings window shown in Figure 41. To view the set parameters
for the types of analysis simulated, click on each tab located at
the top of the Choose Analysis window. On the right side of the
window, you are able to view, which analysis types are enabled.
To enable the Monte Carlo analysis in the AC simulation, click the
Enable Multi Step box in the Monte Carlo and multi-step analysis
section. Click Define to open up the Define Multi Step Analysis
window.

Set the sweep mode to Monte Carlo and enter the Number of
steps, which shows in Figure 41 Number of steps set to 30.
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FIGURE 40. SET TOLERANCES
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FIGURE 41. ENABLE MONTE CARLO ANALYSIS

Click "Run" or press F9 to run the simulation. Figure 42 shows an
example of gain and phase plots for AC simulation. They show
the passband ripple and cutoff frequency variation due to the
components tolerance.
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FIGURE 42. MONTE CARLO RESULTS OF AC SIMULATION

Conclusion

iSim:PE is a powerful offline simulator which complements the
iSim online design simulation tool. This application note
illustrates the most frequently used functions in iSim:PE as a
quick user’s guide. It is not intended to be a complete user’'s
manual of iSim:PE. For any function that is not mentioned here
or for more detailed instructions please see the
Simetrix/SIMPLIS User Manual [1]. If you have any questions

about using iSim:PE, please contact Intersil Central Applications:

email:centapp@intersil.com or tel: 1-888-INTERSIL
(1-888-468-3774).
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